Vintage Mustang Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Vintage Mustang Forum
    Greetings- 1965 Ford Mustang Convertible 289 wouldn't start yesterday in P so it started in N. Today wouldn't start in either (but the radio and power turns on) by this I mean I turn key to start and nothing cranks or happens. No noise except radio and power turning on. So I jumped the...
  2. Vintage Mustang Forum
    All bulbs are good. Brake lights and emerg flashers all working. All turn signals working — except rear drivers side. (Note that I recently replaced turn signal actuator to restore my horn function). Any help appreciated.
  3. Vintage Mustang Forum
    Good morning - rather new member here so apologies if this is misdirected. I’m having issues (cold leak, slippage/delay) with the C4 automatic in my ‘65 Mustang and looking for a reliable mechanic to work on it in the Tampa Bay vicinity. Any suggestions appreciated!
  4. Vintage Mustang Forum
    65' 289 4V GT Rough Idle question I just picked up my first mustang a couple months back and am trying to chase down an ignition / mix issue. I've been having a rough idle since I bought her, and trying to chase down what exactly is going on. It appears to be running rich. So far I have...
  5. New Member Introductions
    Started in Southern California when I bought this upon returning from Vietnam in 1970 with a C4-289 Convertible with 2 barrel carb. Now, 3 engines and 4 transmissions later, it is a built 302 with all Edelbrock, low compression for Paxton Supercharger and B&M modified Ford AOD 4-speed/overdrive...
1-5 of 5 Results
Top