Vintage Mustang Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-8 of 8 Results
  1. Vintage Mustang Forum
    Hey folks, long time member. Had my 66 now for many years. Works great got it dialed in and drive it daily in the summer. It is a great cruiser and can get up and go. Over the years I have done a few performance mods: Replaced the C4 with a T5 Upgraded the rear to reinforced 8” with 3:80...
  2. Vintage Mustang Forum
    Alright so I just picked up a 66 mustang coupe this week and thought I was getting a great deal at 15k ( seller originally wanted 18,500 ) not wanting to miss out I jumped on it and brought her home. Upon more research I feel completely overwhelmed. So first problem the motor is a 302 small...
  3. Vintage Mustang Forum
    Ok everyone, I’m stumped. Working on a 68 mustang with a 302, been trying to install this distributor for 3 hours and no luck. Long story short, I know the oil pump shaft is engaged. My issue is the cam gear and the gear on the distributor doesn’t seem to want to fully engage. Only about...
  4. Vintage Mustang Forum
    Hi Everyone I am installing GT40 heads milled 30 thou on 68 302 for my mustang. Looking at the specs I am looking at using a 0.029 in compressed thickness head gasket. I believe that this is in spec to maintain reasonable compression but I have not seen on the forum post installation details or...
  5. Vintage Mustang Forum
    Hi all, I'm currently working on my 66 coupe, fixing rust issues. Parts started to arrive, all good here. I do have a good opportunity to purchase a 64 GT coupe with a 302 engine. This would allow me to obtain all basic V8 parts at a good price. I would also have a second body to choose from...
  6. Vintage Mustang Forum
    I installed the real main seal it was 2 piece seal and after installing it’s still leaking oil. Can someone help me with what seal is the correct one for pictures below engine. Thank you
  7. Vintage Mustang Forum
    Hi I need help finding correct rear main seal for my 302 Ford engine I’m attaching a picture of my engine number too. I installed 2 piece rear main seal but it’s leaking oil so I need help. Thank you
  8. Vintage Mustang Forum
    Here we go with a new problem! So I have 302 engine in 66 mustang and it’s leaking engine oil when I try to drive it and floor the gas pedal. No leaks at all while the car is idle/running. I can’t even see where it’s leaking from unless I put a small camera and record while driving. No gasket...
1-8 of 8 Results
Top