Vintage Mustang Forums banner
  • Hey everyone! Enter your ride HERE to be a part JUNE's Ride of the Month Challenge!
  • May's Ride of the Month contest ended with a tie! Go to this thread to vote on the winner! VOTE HERE

302 ford

  1. Vintage Mustang Forum
    So I pulled one of a spark plug out and the bottom part looks very black. I’m assuming that’s not how it supposed to be. So I need help on that... like what’s the problem and how to fix it? second problem that I’m seeing is coolant that seemed like it was around the oil pan. I cleaned and...
  2. Vintage Mustang Forum
    So I have a 302 from 83 and C4 transmission in mustang 66. In many problems I’m facing a new problem. So when I test drove the car today it was running very heavy under acceleration. Everything is good. Transmission and of course engine too but I feel like it’s just some adjustments that I’m not...
  3. Vintage Mustang Forum
    So now I think only 1 problem to fix before I can put the car on road. This is what I’m facing now. I recently changed my intake and had to take the dis out. Now I can’t seem to figure it out. My balancer doesn’t have timing written on it. So when I did try to put the dis back in after finding...
  4. Vintage Mustang Forum
    I recently got EdelBrock super victor intake. It’s not fitting properly. One side sits then other side doesn’t sit. I don’t know if this is possible but can you grind the head down a bit to make it fit? Or that’s a no?!?!
  5. Vintage Mustang Forum
    I’m very concerned about my balancer does anyone know why my balancer is shaking a bit? When I idle the car the balancer feels spinning funny and not spinning solidly. I have a mustang 66 and it has a 302 in it. Please help because I’m very concerned. I don’t think I can upload a small clip...
Top