Vintage Mustang Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Vintage Mustang Forum
    I have a ‘65 coupe with a ‘91 5.0 that has an edelbrock carb and pertronix distributor and coil. It’s been running fine the last couple years from when I did the engine swap. Recently it started getting a small random miss, and under harder acceleration it seems like Almost the entire engine is...
  2. Vintage Mustang Forum
    Hello All, I had a long post going previous at 68 - Won't Start and figured I'd start off a new post. I am really confused now. When I measure the voltage at the right side of this connector (red wire - green stripe) I get 12.3 volts when I measure the same wire disconnected at the coil I...
  3. Vintage Mustang Forum
    Wondering if anyone has the part number I need to order a PerTronix Ignitor? My Accel Distributor is a Dual Point Model# 30200 Serial# C10670 Thanks,
  4. Mod and Custom Forum
    I own a 1968 Mustang J-Code 302 4BBL with a single point ignition system. Whether it’s going from points or another version of the ignition system, there are many advantages to installing the Ignitor III. Module. For my car that is daily driven, I was hoping to gain more fuel economy and the...
  5. Vintage Mustang Forum
    I screwed up and left my ignition switch on for a week. I think I damaged my PerTronix Ignitor. I was working on lights and accidentally left the keys in the run position for a week. The battery was completely dead. After charging the battery back up it fired right up! I was relieved but then I...
1-5 of 5 Results
Top