Vintage Mustang Forums banner

1 - 4 of 4 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
My 69 I6 has a 1bbl carb on it. After some problems this week with surging on acceleration it was suggested by fellow VMF'ers I check / replace the accelerator pump on the carb.

I'm now in the position of deciding whether to do a rebuild on the carb (PO did one in Feb of 2002), buy a reman carb from the local parts store or replace just the accelerator pump.
Any recommendations? How often does a rebuild need to be done?

Also, the only identification I could pull from the carb is Motorcraft D0PF C5J19. My shop manual only has specs on autolite and carter carbs. Are there instructions with the carb kit?
 

·
Registered
Joined
·
467 Posts
Hi.
The easiest thing is to replace the accelerator pump, see how it works, if nothing happens, rebuild the carb, but if the carb needs to be rebuild too often your best choice is another carb, you can contact the guys from Pony Carb, they should have the right carb for your ride.
Hope helps.
Fer ::
 

·
Registered
Joined
·
3,595 Posts
Eric,

I went back and referenced your previous post. I question the accelerator pump theory since it was recently replaced, and it probably hasn't had too many miles put on it.

Sounds like you have the Autolite/Motorcraft 1100 (or equivalent). This was never much of a carb, and a simple tuneup kit rarely addresses the problems they have. They get worn in the bushings where the levers enter the body, and develop vacuum leaks.

Anyway, I have a used one that you can have. It has no markings on it, but appears to be a rebuilt unit that somebody gave me. It came off a running car, and had no apparent problems. If you want it, I will give it to you if you will come and pick it up. I live a couple of miles south of US 60, just west of Apache Junction. Heck, I will even help you install it on your car while here, and then we'll know if that was the problem. We might check out the slack in the timing chain while you're here, as that is one of the more common problems on the I6. At least, that way, you'll know. PM me if interested. I can help you on Saturday morning, if you'd like.

I'm leaving here pretty soon, but will be back later this evening, and will answer your PM then.
 

·
Registered
Joined
·
359 Posts
I think you are off base with the accel pump. If its bad you will just dog from the beginning. A surge problem sounds like a fuel problem. Start at the filter at the carb and work back to the pump and then the sending unit (sock).

As for your carb, it may be a autolite/motorcraft 1940. They were popular in 70s. Here is a link to what it looks like.
http://www.geocities.com/mustang_man_1966/autolite_1940_page.html

James
 
1 - 4 of 4 Posts
Top