Vintage Mustang Forums banner

'65 Alternator Wiring

421 21
I have a yellow wire connected to the STA terminal on the back of the alternator.

Looks like the villainous PO set it up. I added the other wire that runs to the choke [on the SUM MV2008].

Going to a MC solid state voltage regulator causes the ALT light to flicker.

Any troublshooting help would be appreciated.

Hood Automotive tire Motor vehicle Automotive fuel system Vehicle brake

Automotive tire Motor vehicle Automotive fuel system Rim Vehicle brake

Automotive tire Motor vehicle Automotive exterior Gas Automotive wheel system

Rectangle Font Line Slope Parallel
1 - 10 of 10 Posts

·
Registered
Joined
·
584 Posts
Discussion Starter · #7 ·
Black + yellow tracer = BAT
White = FLD
Yellow = black tracer = STA [will move to BAT]
Balck + red tracer = GRD
Black = STA for choke.

Sound right?

Thank you @Woodchuck 12 yo scotch next time you are in AZ?
 

·
Registered
Joined
·
584 Posts
Discussion Starter · #10 ·
New harness installed as well as Motorcraft VR.

Still getting a red blinking ALT light. About 14.2 - 14.5 volts while idling.

Could the alternator be messed up?
 

·
Registered
Joined
·
584 Posts
Discussion Starter · #22 ·
@22GT correct. New harness has a plug for it but I’ve not put in the capacitor-at the alternator nor at the VR.

Alternator is a replacement (has Motorcraft embossed on the back).

I notice you are missing the static suppression condenser. They are available in nice repro. That's a 65-only item. The new harness should have a plug for it.
 
1 - 10 of 10 Posts
Top