Vintage Mustang Forums banner
  • Hey everyone! Enter your ride HERE to be a part JUNE's Ride of the Month Challenge!
  • May's Ride of the Month contest ended with a tie! Go to this thread to vote on the winner! VOTE HERE
1 - 4 of 4 Posts

·
Premium Member
Joined
·
417 Posts
Discussion Starter · #1 ·
I have a problem where the clutch pedal pivot shaft clip will pop off after depressing the clutch pedal a few times(random times). I checked all the linkage and it all looks great and aligned. My guess is the EL'CHEAPO AUTOZONE'O clutch is too stiff and requires more force than my poor little 65 pedals can muster. I'm sure someone is going to suggest the removal of the presure plate and a new replacement but I hate to do it since I just installed it a couple weeks ago. Has anyone else ever had this issue? I will say that once the clip falls off and the shaft slips out it is MUCHO pain in the a$$ to correct. Thanks for any advice or kind words.Olaf
 

·
Registered
Joined
·
1,334 Posts
Olaf,

Can you be more specific about which part is poping off? Is the clutch pedal shaft slipping out of the clutch pedal hanger? Your clutch pedal hanger may be worn out.

Here's a good link to a nice repair - http://www.mustangsteve.com/clutchbearings.html

Here's a diagram for reference



Tim
 

·
Premium Member
Joined
·
417 Posts
Discussion Starter · #3 ·
The clutch pedal is sliding sideways. The bushings are fine and the plastic sleeves are all in there also. I also have the correct clip .
 

·
Registered
Joined
·
10,527 Posts
I had that problem.

I changed the clip to a C clip and solved the problem.
 
1 - 4 of 4 Posts
Top