Vintage Mustang Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter #1
Was driving the car today and noticed that i had no power to the fuel gage, oil press gage, water temp gage, and no turn signals....also wired to the ACC side are the radio and tach, both not working. I've did some wire chasing and everything looks good....i'm thinking it may be the ignition switch has gone bad. From the looks of the schematic all theses acc's run through the ign switch. What do you think?
 

·
Registered
Joined
·
6,008 Posts
I would agree with you except for the turn signals. That throws me off a bit unless it is just coincidental that they don't work too.

Dumb question - you've checked the fuses?

Is it left/right and front/rear turn signals that don't work or just the indicators on the dash?

Do tour tail lights and parking lights work?
 

·
Registered
Joined
·
177 Posts
Discussion Starter #3
Fuses are good and grounds are good....tail lights, headlights, and brake lights are good. Everything worked for a brief moment when i was playing with it last night then it all went dead again
 

·
Registered
Joined
·
1,066 Posts
How about the ground wire that attaches behind the instrument housing to the frame? That's one that can come loose with "playing"
Get a simple volt meter or test light and follow the current until there is none.
 

·
Registered
Joined
·
197 Posts
Check your headlight switch. I'm not sure about the AC running through there, but everything else that you mentioned goes through the light switch. It might have a short or something like that and would give you a heck of a headache. That would be my suggestion to check. Good luck finding the problem either way.
 

·
Registered
Joined
·
6,008 Posts
Chris Richardson said:
Fuses are good and grounds are good....tail lights, headlights, and brake lights are good. Everything worked for a brief moment when i was playing with it last night then it all went dead again

Then I would look for a loose connection. The turn signals aren't fed from the ACC side but if it is only the turn signal indicators that don't work then it could be the ground to the instrument panel that would explain everything.
 
1 - 10 of 10 Posts
Top