Vintage Mustang Forums banner

1 - 3 of 3 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Ok for the thrid time I had to replace my control valve becasue of the bogus rebuilder, now I just had a freind do it for me at my house so I wasnt their to see what he did.

He connected the lines etc, so now after two weeks I get the car started to see if the system is working and here's what happedn

I topped of the fluid sine it most leaked out, now I go to turn the steering wheel and it turns to thr left nicely and it doesnt barley turn to the right at all, it feels like their isnt any power steering,

so my conclusin is did this clown mix up my lines if so which ones so I can fix it. As soon as I shut the motor off the fluid in the PS pump stated overflowing throught the cap all over the driveway again.

I have had it today with this car, hope someone can respond soon so I can fix this.

Thanks
 

·
Registered
Joined
·
1,488 Posts
not to be a jerk or any thing like that. If you want to drive it for now until you get it fixed, take the belt off the ps pump pulley. Yes, its manual steering now but you can drive.
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Maybe the valve is not centering. Are you certain that the adjustment nut on the centering spring rod is set properly? Does steer left when raised?
I've been through that problem before and an adjustment of the nut by a thread or two corrected the problem.

http://www.jps.net/binay/webdocs/Images/mustang01.JPG

"Sometimes a man's life can depend on a mere scrap of information."-The man with no name
 
1 - 3 of 3 Posts
Top