Vintage Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Just finished rebuilding the P/S control valve and reinstalled it back on the car. Replaced the fluid and started the car. The steering wheel started rapidly moving left to right then turned all the way to the left. Very difficult to turn back. What did I do wrong?

http://albums.photopoint.com/j/View?u=1599118&a=12185591&p=44290013

Terry
 
G

·
Guest
Joined
·
0 Posts
Disconcerting isn't it?
This sometimes happens as the system is purging of trapped air. Let the car idle for about 2 min. to warm the fluid up. Then turn the wheel fully right then left several times to purge the air. Now increase the engine speed to 1000rpm and repeat turning the wheel fully right to left several times to continue the purging. turn off the motor and check for leaks and to refill the fluid if needed. If all has gone well with your rebuild and the valve adjustments are correct then the wheel will have equal effort to turn right and left


Greg B
 

·
Registered
Joined
·
408 Posts
Depending on how far you disassembled the valve you may also need to re-center the spool. This is done with the bolt behind the end-cap. The procedure is outlined in the shop manual.

Scott
National Parts Depot
1965 Conv:Street driven concours
1966 Coupe: Daily driver and toy
 

·
Registered
Joined
·
39 Posts
Discussion Starter #4
Thanks for the f/u. I did think the problem was related to the centering nut but in an attempt to adjust it I ended up stripping the threads. Just finished removing the valve and will attempt to get another shatt tomorrow. Air, who would have thought?

Terry

http://albums.photopoint.com/j/View?u=1599118&a=12185591&p=44290013.jpg
 

·
Premium Member
Joined
·
1,404 Posts
Make sure you have the hoses routed correctly!!!
Reverse the hoses between the valve and the ram and the steering acts as if possessed!
Experience can be a harsh teacher.
Dave
 

·
Registered
Joined
·
39 Posts
Discussion Starter #6
Problem turned out to be both air and misrouted lines. Possessed is right, though. Works fine now. Thanks.

Terry
69 Grande, 351W,4 sp
69 Convertible, 302, auto
69 Mach I, 390, 4 sp

http://albums.photopoint.com/j/View?u=1599118&a=12185591&p=44770693.jpg
 
1 - 6 of 6 Posts
Top