Vintage Mustang Forums banner
  • Hey everyone! Enter your ride HERE to be a part MAY's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
1,079 Posts
Discussion Starter · #1 ·
Well, ive been out here all day trying to get this right. I have a holley 850 cfm carb that im trying to get running right, and its giving me all the trouble in the world. I can get my car to start, but it runs like crap and there is tons of black smoke. I did a search on this and couldnt find anything... all the search told me is that i may have a vaccume leak. Ive gone through and replaced a few gaskets, tightened all the screws and all that, still the same thing. Does anyone know whats going on here?
 

·
Registered
Joined
·
1,426 Posts
well i don't know too much bout carbs... but is that 850 for the 351w you have in your bio? that seems pretty big even for a modified engine
 

·
Registered
Joined
·
526 Posts
Most likely it's not a vacuum leak because of the black smoke. Black smoke is caused from a rich condition. Possibly you have misadjusted the float level or got dirt in your needle seat. After you fix the actual problem you may need to clean or replace the spark plugs if the engine has a miss. Pull one out and see if it is black.
 

·
Registered
Joined
·
2,987 Posts
you will have a tought ime getting the car to run perfect with an 850cfm carb on a 351W. For one the intake ports are WAY to samll to support that kind of CFM. To give you an idea. An 859 is too big for my 429 you need top get into some pretty big cubes and HP to support that big of carb. There is all kinds of theory I could sport here but won't. But yes Black is way to rich, you need to start jetting down.
 
1 - 5 of 5 Posts
Top