Vintage Mustang Forums banner
  • Hey everyone! Enter your ride HERE to be a part JUNE's Ride of the Month Challenge!
  • May's Ride of the Month contest ended with a tie! Go to this thread to vote on the winner! VOTE HERE
1 - 3 of 3 Posts

·
Registered
Joined
·
12,305 Posts
Discussion Starter · #1 ·
Just wanna publicly say thanks to Dave Sanborn for sending me some O2 sensors!! Thank ya! I think it's restored some of my mojo.

Now a question for those who have installed O2 sensors. I'm wondering how you did it (I"m not even sure how they were done on Fox's). I have the wiring harness uncovered so I can route the O2 Y-harness and it's main connector (Off the main harness) anywhere. IE, I can fold it back to bring it closer to the firewall. But where should I go from there? Right down the center onto the tranny? Seems like a bad idea.. Down a side of the engine, but then I'll have dangly wires.. And also, I assume the Y connector should hang inside of the manifolds (I'm running long tube Tri-Y's, so the O2 bungs are at the top of the collectors, about in the middle of the tranny), and then underneath the transmission or something? What did you guys do?

Thanks again!!
 

·
Registered
Joined
·
4,971 Posts
Johnny,

You and the rest of the EFI guys have proved to be an invaluable asset while I've muddled through my swap. It's the least I could do.

Thank You!

Dave
 

·
Registered
Joined
·
12,305 Posts
Discussion Starter · #3 ·
And I GREATLY appreciate it! If you need anything I might have here, just ask. ALthough, as I've stated before, you've come rocketing past me in the race for EFI. :lol:
 
1 - 3 of 3 Posts
Top