Vintage Mustang Forums banner
  • Hey everyone! Enter your ride HERE to be a part MAY's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter · #1 ·
My brake lights dont work. The turn signals work fine and when I put the head lights on the tail lights come on but the brake lights still dont work. What do I need to do? Do you think the bulb is bad maybe? Do you think the switch at the pedal is bad?? I need somethings I can try.
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #3 ·
I got a new switch made sure it worked with a test light(dont have a meter). I put it in and now that lights wont turn off wheter I hit the brakes or not. I havent put the spring back do you think that will make a difference??
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #5 ·
I got smart, I tested the old swtich again. Apperently it wasnt bad. Upon further inspection I see that one of the wires that goes into the plug had been cut and replaced. As far as the spring not being removable that could be true. The spring I have just clips behind the brake pedal and into a hole at the bottom of the dash. I cant seem to find some kind of exploded view of this in any of my books. Maybe someone could set me straight or give me the site of something with picture of how all this is supposed to look. I also think that part of the problem is that one of the bushings might have been on backwards. What I really need is some kind of picture of what the correct setup looks like.
 
1 - 5 of 5 Posts
Top