Vintage Mustang Forums banner
  • Hey everyone! Enter your ride HERE to be a part MAY's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
After 2 years, I have finally started driving my 65 FB. Engine is a 302 HO from an 84 Mustang GT. I seem to have developed a stutter or stumble at just off idle speeds. Whenever I let off the accelerator for a second or two, to coast, or to shift, ( 4-speed), the car sort of stumbles for just a second, then is fine. On hard acceleration, the car bucks for a second, then goes like hell thru all four gears. All electricals are new, and I have a new Edelbrock 1404 (500 CFM) carb. It is a manual choke, and I have the choke plate firmly fixed. Idle is rich, but I cant seem to lean it out very much, but plugs look good. The car runs very well. just bucks a little on light acceleration, and when I let off the gas for a few seconds. Any suggestions ?? I know that these performer carbs are easily tuned with metering rods etc. but I dont know where to start.
 

·
Registered
Joined
·
4,077 Posts
I would start with the power or accelorator pump. Make sure it is a 50cc unit...it might be kicking in a little late in relation to the throttle position.
 

·
Registered
Joined
·
6,070 Posts
almost sounds like you might need a bit more advance on the timing
 

·
Registered
Joined
·
6,911 Posts
get the calibration kit...it's inexpensive.

rod changes are easy; a screw holding a cover and you've got it...the rods have 2 dimensions..the larger one is for cruise, the smaller for power

the jets require the airhorn to come off..still easy...the rods stick thru the jets, so the jets affect power and cruise modes

verify your ignition first!
 
1 - 4 of 4 Posts
Top