Vintage Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,488 Posts
Discussion Starter #1
I recently purchased, and partially installed a Moroso electric water pump. It is simple enough but takes up a bit of pulley space. I haven't tried yet but those of you with one, where you able to mount your alt. in the same place as before? If not, could I hear some suggestions with details or pics of set-ups please? I'm 2 years into a 3 month project and really want to drive it. I've been very patient, doing it right this time. Thanks for any imput.
Bart
oh, its on a 302 with a 3 groove crank pulley if that makes a difference.
 

·
Registered
Joined
·
1,888 Posts
I'm not sure what the Moroso electric water pumps look like, off the top of my head. But I've got a CSI water pump on my fastback. Here's what I did to make my alt work:

I took a piece of plate aluminum (just what I had laying around in the garage) and cut it into basically a triangle...to drop the alt down far enough so the belt don't rub the water pump. The alt is actually rotated 180°, so the threaded hole is at the top. For the top and the adjustment. I picked up two heim joints (aka rod ends) and a piece of hex steel. I drilled and tapped both ends, one is right hand thread and the other is left hand thread. I bolted to the top middle bolt of the timing chain cover -- I believe that can be seen in my sig photo -- and the other to the alt. Made several trips to the auto parts store to get a belt the correct size, put it on and tightened it up.

It works good. If this is something you think would work with your setup, I can try and get some more photos.
 

·
Registered
Joined
·
1,488 Posts
Discussion Starter #3
That looks like it will work, and a cool looking set-up at that. I like making my own parts. Thank you.
 
1 - 3 of 3 Posts
Top