Vintage Mustang Forums banner
  • Hey everyone! Enter your ride HERE to be a part JUNE's Ride of the Month Challenge!
  • May's Ride of the Month contest ended with a tie! Go to this thread to vote on the winner! VOTE HERE
1 - 7 of 7 Posts

·
Registered
Joined
·
209 Posts
Discussion Starter · #1 ·
Gents,

I got my '70 back from the body shop (fixed major wreck damage and painted car) and there are a few electrical problems that need straightening out.

-parking lights/front turn signals don't work

-when headlights are on, both dash lights for the turn signals light up solid and don't blink, whether turn signal is on or off

-interior lights don't come on

-hazard switch doesn't work

The turn signals work fine when the headlights are off.

Could this be a faulty turn signal switch or headlight switch, or is it something more hellish?

Thanks,
Joseph Knight
 

·
Registered
Joined
·
3,245 Posts
My only guess would be a headlight switch, it's the only common denominator(that I can think of) between all of those circuits. You should probably get a few more opinions before taking my opinion on it, but that's the only thing I can think of.
 

·
Registered
Joined
·
992 Posts
Check your bulbs and make you don't have a 1156 in where a 1157 should be or vice versa. Sounds like a feedback problem.

Sluggo
 

·
Registered
Joined
·
654 Posts
This won't be all of the problem but you might want to check electrical contacts at light bulbs, parking light bulbs, etc. When mine came back from painting some of the contacts got paint on them and by cleaning up the contacts fixed my problems. Good luck.
 

·
Registered
Joined
·
2,364 Posts
When mine came back from painting some of the contacts got paint on them and by cleaning up the contacts fixed my problems. Good luck.[/quote]
What did u use to clean it with
 

·
Registered
Joined
·
2,364 Posts
thanks jerry
 
1 - 7 of 7 Posts
Top