Vintage Mustang Forums banner

1 - 3 of 3 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Have '67 fsbk with 289 4v, engine starts fine, so quiet sometimes I wonder if it's running. After the initial 15-20 seconds of running, I touch the gas for a second. That moves a piece on the carb(can't think of the that piece name right now) lowers the engine speed a bit. In park and neutral the speed is fine, (approx 500 -525 rpm). Manual says, 525rpm in drive, have turned distributor, left and right to speed up engine. Then turn idle mixture screws. Engine in drive still at 375-400 rpm. Engine dies around 350 rpm.
 

·
Registered
Joined
·
673 Posts
I believe you need to turn your idle screw up a bit (it's the little screw that holds the throttle engaged a bit on the carb.

Oh, and was "fast idle" the term you were looking for?

Thespazardman

/forums/images/icons/blush.gif/forums/images/icons/cool.gif/forums/images/icons/crazy.gif/forums/images/icons/frown.gif/forums/images/icons/laugh.gif/forums/images/icons/mad.gif/forums/images/icons/shocked.gif/forums/images/icons/smile.gif/forums/images/icons/tongue.gif/forums/images/icons/wink.gif

[color:purple]1968 C Code Coupe with C4
swapped in J Code and Toploader 4 speed
</font color=purple>

/forums/images/icons/blush.gif/forums/images/icons/cool.gif/forums/images/icons/crazy.gif/forums/images/icons/frown.gif/forums/images/icons/laugh.gif/forums/images/icons/mad.gif/forums/images/icons/shocked.gif/forums/images/icons/smile.gif/forums/images/icons/tongue.gif/forums/images/icons/wink.gif
 

·
Registered
Joined
·
5,205 Posts
I agree... The only thing I can think of is that you need to

a.) let the car warm up more in morning before disengaging fast idle
and
b.) turn the idle screw in about 1/2 turn
 
1 - 3 of 3 Posts
Top