Vintage Mustang Forums banner

1 - 20 of 34 Posts

·
Super Moderator
Joined
·
9,052 Posts
Discussion Starter #1
Whilst driving to get dinner tonight, this happened to my ‘99 4Runner. Fortunately, I was alone and only traveling 25-30 MPH. No bumps, no potholes, no dips...catastrophic failure. No brakes, no steering.

 

·
Registered
Joined
·
2,355 Posts

·
Registered
Joined
·
2,343 Posts
Wow that stinks glad to hear that you are alright. You didn't have any warning? It just snapped? Definitely good you weren't going to much faster.
 

·
Registered
Joined
·
2,186 Posts
If you have collision coverage....you must have hit a pot hole and then this....it pays for resulting damage, but not the cause, such as a wore out cv joint.........worth a call if nothing else...
 

·
Registered
Joined
·
4,338 Posts
Am I seeing the pic right... did the LCA just snap???

I had a LCA snap on me on an 86 Toyota truck back in like 1997, but it was a horribly rusted NY truck. I was actually lucky it was damn near a blizzard out, so I was only going 10 mph.
 

·
Super Moderator
Joined
·
8,929 Posts
Think Interstate @ 75 mph,.....could have been much worse! :surprise:
 

·
Registered
Joined
·
1,805 Posts
Wow !

Glad you're ok.

John
 

·
Super Moderator
Joined
·
9,052 Posts
Discussion Starter #13
Bad design for this model year apparently. The Lower ball joint is under tension rather than compression allowing it to separate after normal wear. Shame on me for not having replaced them when I purchased the vehicle...315K miles.

https://www.toyota-4runner.org/3175578-post169.html

The ball and pin are still 100% in tact. The boots weren't even cracked.
 

·
Registered
Joined
·
8,476 Posts
You might want to check the brakes while you are at it !!!
 

·
Premium Member
Joined
·
6,679 Posts
But what about the ROAD ??

No pictures of the pavement. Was it concret, asphalt, macadam, what?

Were there any injuries to the road surface?

We need to focus on the important things.
 
1 - 20 of 34 Posts
Top