Vintage Mustang Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,068 Posts
Discussion Starter #1
While crusing last night, my tack needle stuck at 4K. The damn thing won't move.
 

·
Registered
Joined
·
1,652 Posts
Hold old is the tach?

I had a problem with my an Autometer tach of mine, sent it back to them and they replaced it free of charge. IIRC, the warranty period was within a year
 

·
Moderatly Old Fart
Joined
·
4,428 Posts
AutoMeter is great! I had a bulb burn out and they sent a replacement in the mail.

When I was hooking up a tach in my pick up the instructions said to hook the wire to the coil. Which one? There are 4! A quick call to technical support took care of in a hurry.
 

·
Registered
Joined
·
327 Posts
H2O temp gauge has problems sticking sporadically. Purchased new, installed 3 mos ago. Worked fine for a couple weeks. May be a loose connection/wire that I haven't checked out yet, so haven't contacted autometer.
 

·
Registered
Joined
·
1,068 Posts
Discussion Starter #5
I bought a JME bezel with Autometer gauges through a VMF group purchase about 5-6 years ago.
Everything worked fine until last night. It is probably out of warranty, unless it is a lifetime warranty.
 

·
Premium Member
Joined
·
3,428 Posts
Autometer has a repair shop and charge a flat fee, depending on which gauge.

My tach just shelled out also. Need to pull it and send it in.
 

·
Registered
Joined
·
2,109 Posts
My Auto meter tach does not return to zero when off! Too much trouble to take it out cause it is built into cluster.
 

·
Registered
Joined
·
4,657 Posts
Try turning the key to accessory after you turn the car off and then back to off and see if that returns it to zero. That's what I have to do on mine.
 

·
Registered
Joined
·
1,068 Posts
Discussion Starter #9
Thanks, I'll try that.
 
1 - 9 of 9 Posts
Top