Vintage Mustang Forums banner

21 - 40 of 40 Posts

·
Registered
Joined
·
1,188 Posts
Discussion Starter #24
It’s fighting me every step of the way.
Got driveshaft in after about 4 of trying yesterday and today.
Tonight.... more starter problems.
Neither of these are fitting good.
And $350 later, not sure what to do....




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
136 Posts
Well the transmission is back in....
Only enough, it almost fell in.....
I was able to get it stabbed in by myself. Not sure how. All on my back in the garage.


Then.... as does typically happens, it took me 4 hours to put the drive shaft in.
The new heavy duty output shaft was so crisp and new, the drive shaft held up about 1/4” from going in the transmission. A friend came over and we FINALLY got it in. Was probably the smallest of burrs on it.

All I lack is the starter, exhaust, and transmission lines to the front cooler.
There is a slight chance I make it to the track tomorrow.
Probably not, but maybe.




Sent from my iPhone using Tapatalk
Isn't that the way it always goes...Good for you for getting it back together as fast as you have!
 

·
Registered
Joined
·
136 Posts
It’s fighting me every step of the way.
Got driveshaft in after about 4 of trying yesterday and today.
Tonight.... more starter problems.
Neither of these are fitting good.
And $350 later, not sure what to do....




Sent from my iPhone using Tapatalk
Oh dang! I just posted and then saw this! Are you sure they match the bellhousing and flexplate, 164 vs. 157?
 

·
Registered
Joined
·
1,188 Posts
Discussion Starter #27
Place your bets!!! I’m pulling in the drag strip to grudge race @ “crank it up”.
Aka Stephen



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
236 Posts
Taking my car to the drag strip for the first time on the 15th.
Curious to see what people’s guess is.

Details.
Car. 68 coupe
Engine 381ci Cleveland
Engine Dyno on stand was slightly over 500hp.
Car probably weighs 3000lbs.
4.11 locker in rear.
Back halfed 18” wide MT tires.
Super Sniper/hyperapark carb,dizzy.
Powerglide 2speed tranny, with transbrake.

What say you.
What’s your guess?





Sent from my iPhone using Tapatalk
Sounds like a 10.5 setup to me.Its up to the driver and your experience with the lights on the tree.
yarb
 

·
Registered
Joined
·
1,188 Posts
Discussion Starter #32
Sounds like a 10.5 setup to me.Its up to the driver and your experience with the lights on the tree.
yarb
I think it has a lot more to it.....
I think it can break 11.0 anyway....

Thanks for all the input guys!!!




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,188 Posts
Discussion Starter #33
Here is video from dash cam on Buddies car in other lane.....






Sent from my iPhone using Tapatalk
 

·
Dimples
Joined
·
3,519 Posts
Nice work!
I have to pat myself on the back. Within 3 tenths and 1mph. ;)

Though NextGen almost nailed it with that 11.85 prediction. I’m sure you can break into the 10s with some more practice and tuning.
 

·
Registered
Joined
·
16 Posts
My 66 should be making similar power and ran 11.60 @ 121 on its first 2 passes with mediocre 60ft times. You've got way more tire than I do so I would think 11 teens is attainable with more track time
 

·
Registered
Joined
·
721 Posts
nice ! that thing hooks and goes. looks like you were baby'n it lol, i see it picking up a lot with harder launches
 

·
Registered
Joined
·
1,188 Posts
Discussion Starter #38
nice ! that thing hooks and goes. looks like you were baby'n it lol, i see it picking up a lot with harder launches
That’s fair....
It was the first pass ever on track.
I only launched at around 2800 rpms.




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
136 Posts
Congratulations on making the passes. Looking at the slips I would be more focused on the trap speed rather than the et, trap speed is more indicative of power. Looking at the the eighth mile trap speed it appears something is way off...With the power you are making you should be trapping around high 80s, low 90s, the et looks about right. For the quarter mile your et looks about right for soft launches but the miles per hour (trap speed) looks low for how much power you have. If you run your numbers through the Wallace calculator http://www.wallaceracing.com/et-hp-mph.php it would suggest your power is down or the listed speed is wrong.

Do you think the strip was having issues with it's timing equipment? Do you know what the altitude of the track is? Tracks at high altitude result in low trap speeds. Are you sure about the weight? If it weighs more than you think that would explain the lower trap speed in the quarter. NOTHING explains the trap speed listed in the eighth. That must be a misprint or mistake. 96 mph in the 8th sounds more like what the car is capable of, not 46!

Beautiful car! Good luck!
 

·
Registered
Joined
·
1,188 Posts
Discussion Starter #40
Yea, that’s weird.
Didn’t notice that.
That first speed is definitely wrong.
I thing the 1/4 trap speed is correct.



Sent from my iPhone using Tapatalk
 
21 - 40 of 40 Posts
Top