Vintage Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
I have been trying so hard to get my 289 in but I keep running into problems,
Problem # 4,359
The alternator and main crank pulleys both line up fine, but the water pump pulley is about a centimeter forward, If it was back, I could just use spacers, but its forward. Do I simpley have the wrong pulley? The water pump itself is factory and fits perfect so I dont think its the pump. If anyone else has hit this problem please help me. Thanks
 

·
Registered
Joined
·
359 Posts
What's the provenence of all the pieces? Alternator bracket, pulleys, water pump, and especially timing cover -- generally speaking, if all of these came from a 289 of the same period, everything should line up. If you've got mixed and matched pieces, well, that's another story. Please post more details.
 

·
Incorporated Sell Out
Joined
·
17,130 Posts
If you are running an aftermarket balancer it will have a spacer for adjusting the crank pulley depth to line up with the water pump.
 

·
Registered
Joined
·
369 Posts
I had to take mine "Victor" to a machine shop to have the pulley pressed farther on the
shaft to get mine to get mine to line up.
 

·
Registered
Joined
·
884 Posts
Hey James, you are not a big help. Yes something is wrong and it maybe the pulley. How about taking the pulley off and giving us the pulley number. Also what else are you running, a/c, p/s? Then we have something to work with.

Don
 
1 - 5 of 5 Posts
Top