Vintage Mustang Forums banner

1 - 7 of 7 Posts
G

·
Guest
Joined
·
0 Posts
Discussion Starter #1
my horn works but only under one condition! (I am not that good with names, i only describe the objects)! I put on that circle piece that helps make the noise when you push it in but when i put the wheel on the horn keeps going! It doesnt give me that effect of pushing in the horn, it just goes in automatically and it doesnt stop until you take off the wheel!
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #2
What year is your car?

Jerry

The FAQs, nothing but the FAQs: http://www.geocities.com/a65ragtop/VM_FAQ

If you can't [color:red]dazzle</font color=red> [color:green]them</font color=green> [color:yellow]with</font color=yellow> [color:purple]brilliance</font color=purple>, baffle 'em with bull
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Justin:

From the nature of the questions you're asking (this post plus window rollers plus leaking etc.), it sounds to me like a 1965 Shop Manual would be a good investment for you. Cost is about $40 at most Mustang parts places (see my FAQ---link in sig below---for places to get them).

The shop manual is a comprehensive guide to everything in the car. It's what Ford published so that its service centers would know how to fix just about anything that might go wrong.



Jerry

The FAQs, nothing but the FAQs: http://www.geocities.com/a65ragtop/VM_FAQ

If you can't [color:red]dazzle</font color=red> [color:green]them</font color=green> [color:yellow]with</font color=yellow> [color:purple]brilliance</font color=purple>, baffle 'em with bull
 
G

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Whenever you try to blow the horn in mine, it shorts out the radio, lights, and anything else electrical until you let off of it. And even then, the horn still doesn't make any noise.
 

·
Registered
Joined
·
4,082 Posts
1st, do you have a spring in there? Ya gotta have a spring. My horn quit working a while back. I ended up having to add small washers behind the contact ring. The two contact post had worn too much. Sounds like your's is making contact all the time. Somethings too close. Check your installation again.

66 Coupe, 302, Auto, 3.25 gears. Candyapple Red with White Pearl Stripes. Cragars.
 

·
Registered
Joined
·
8,476 Posts
I had this problem recently with my VW plus the volt meter would dive to zero when I attempted to honk the horn. After opening everything up and diagnosing the circuit, I determined that the horns themselves were shot. I thought I was the only one to wear out my horns...it's good to know there are others out there with the same problem!!! New horns and it works fine.

67 Vintage Burgandy 390GTA with most of the bells and whistles
 
1 - 7 of 7 Posts
Top