Vintage Mustang Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
Got the stang back from the shop having the front springs replaced. The ride is great, height is perfect, but it makes racket now when I hit bumps. Before the change it was quiet (except for the scraping noise of my tires hitting the fender!!). It sounds like a metal to metal clanking sound. I got underneath and yanked on everything possible and nothing seems loose. Before I take it back to the shop, does this sound normal or is there anything else I can check?
 

·
Registered
Joined
·
5,217 Posts
sounds like they didnt instal the spring rubber insulator
 

·
Registered
Joined
·
370 Posts
maybe the spring isn't spun all the way around an resting against the spring perch stop tab. My would be the spring insulators as well.
 

·
Registered
Joined
·
571 Posts
sounds like they didnt instal the spring rubber insulator
This.

I just replaced mine because they had completely disintegrated, and I had the same problem.
 

·
Registered
Joined
·
9,844 Posts

·
Registered
Joined
·
316 Posts
Got the stang back from the shop having the front springs replaced. The ride is great, height is perfect, but it makes racket now when I hit bumps. Before the change it was quiet (except for the scraping noise of my tires hitting the fender!!). It sounds like a metal to metal clanking sound. I got underneath and yanked on everything possible and nothing seems loose. Before I take it back to the shop, does this sound normal or is there anything else I can check?
There should be virtually no sound. Get a schematic of the front suspension and number each item in the drawing. When you take it back do a check list to ensure; A.that you have the part and B. that it was properly installed. Do not let them rush you through this. Its your baby not theirs.....:idea:
 

·
Registered
Joined
·
103 Posts
Discussion Starter #9
Thanks guys - I checked for the rubber insulator (my first thought too) and it's in place. I'll have to take it back to the mechanic and let him figure it out. Thanks for all the input!
 

·
Premium Member
Joined
·
10,938 Posts
shouldnt make noise ! maybe they didnt grease the a-arm bushing and its making a noise insted of squeeking. even all my roadrace type stuff is > sssshhhhhhh > quiet. take it back. could be the spring insulators are missin like the other replys stated.
 
1 - 10 of 10 Posts
Top