Vintage Mustang Forums banner
  • Hey everyone! Enter your ride HERE to be a part September's Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
1,135 Posts
Discussion Starter · #1 ·
BURP!!!!! Just kidding, I got my Gas pressure gauge I ordered from JEGS hooked up last night and it's reading at 6 PSI at idle. That seems a little low to me, Or is it just fine. I just have a replacement mechanical pump on there but i do have a Electric pump gathering dust in my garage I could slap on there. It's a generic inline pump that was rated at 9 pounds if i remember right. It says to mount it as close to the tank as possible, could I run a wire to it from the gas sender wire? Or should i run a new circut? Well if 6 pounds is OK I'll just leave it be. I have a 1406 carb if that matters. TIA

AKA "Fastbackpimp"
http://hometown.aol.com//dasbus73/Index.html
[color:blue]VMF Member Since Nov. 99</font color=blue>
http://albums.photopoint.com/j/View?u=1590185&a=12106882&p=43855504.jpg
 

·
Registered
Joined
·
10,588 Posts
6 psi is fine....just stick with your mechanical pump for now...

For comparison, try running the engine up to around 5K and check the guage reading......shouldn't be under 4psi

Pat
http://www.jps.net/binay/webdocs/strtmstng002_sml.JPG
 

·
Registered
Joined
·
1,135 Posts
Discussion Starter · #6 ·
Thanx, I did rev it up and it dropped a little down to 5.5 and a little below 5 if I really got on it. It seems to run fine and I don't race it so I'll leave it alone.......For Now

AKA "Fastbackpimp"
http://hometown.aol.com//dasbus73/Index.html
[color:blue]VMF Member Since Nov. 99</font color=blue>
http://albums.photopoint.com/j/View?u=1590185&a=12106882&p=43855504.jpg
 
1 - 6 of 6 Posts
Top