Vintage Mustang Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
203 Posts
Discussion Starter #1
Here's my story -
65 conv with 306, afr heads, weiand stealth, 600 cfm summit carb, tri y's, custom cam.

Installed the custom cam in the spring and have been tuning idle ever since. Off idle it runs like a scalded dog. But I can't get it to idle right.

It will start it up and it will fast idle at 1500rpm until I stab the gas pedal than it will go right down to 750 rpm. Drive around for awhile and come to a stop and it is up at 1000-1100 rpm and won't come down.

I fixed a vacuum leak in my brake booster and things settled down for a bit - but now the fast idle is back. My secondary transfer slots are closed, and my primaries are opened about a turn and a half.
I know I should measure the actual transfer slot opening, but I am tired of pulling this carb... I have played with secondary slot open and primary closed multiple times.

It has sight plugs for the floats and they are spot on.

The cam makes tons of dynamic compression and is a bit lumpy.

thoughts for additional troubleshooting? I've got an Edlbrck 500 I may put on it just to see...
 

·
Registered
Joined
·
106 Posts
Check the choke.
Sounds like what mine was doing. My air cleaner was tightened down to where the choke wasnt opening all the way.
But if it isnt opening all the way it will think it isnt warm and never release.
Here's my story -
65 conv with 306, afr heads, weiand stealth, 600 cfm summit carb, tri y's, custom cam.

Installed the custom cam in the spring and have been tuning idle ever since. Off idle it runs like a scalded dog. But I can't get it to idle right.

It will start it up and it will fast idle at 1500rpm until I stab the gas pedal than it will go right down to 750 rpm. Drive around for awhile and come to a stop and it is up at 1000-1100 rpm and won't come down.

I fixed a vacuum leak in my brake booster and things settled down for a bit - but now the fast idle is back. My secondary transfer slots are closed, and my primaries are opened about a turn and a half.
I know I should measure the actual transfer slot opening, but I am tired of pulling this carb... I have played with secondary slot open and primary closed multiple times.

It has sight plugs for the floats and they are spot on.

The cam makes tons of dynamic compression and is a bit lumpy.

thoughts for additional troubleshooting? I've got an Edlbrck 500 I may put on it just to see...
 

·
Registered
Joined
·
33,680 Posts
WHICH Summit carb? Are we talking about the "new" M2008 series? Have you done any secondary "tuning", like changing the diaphragm spring? Did you lose the check ball? Is the diaphragm gasket portion properly situated?
 

·
Registered
Joined
·
203 Posts
Discussion Starter #4
The carb is the 600cm m2008 series. The only secondary tuning I have done is adjusting the secondary throttle plate opening (it is set closed right now).

I get approx. 16 inches of vacuum at idle (I was at 22 with the stock 5.0 HO cam). I thought that was enough vacuum to not change anything on the secondary - am I wrong?
 

·
Registered
Joined
·
5,737 Posts
Here's my story -
65 conv with 306, afr heads, weiand stealth, 600 cfm summit carb, tri y's, custom cam.

Installed the custom cam in the spring and have been tuning idle ever since. Off idle it runs like a scalded dog. But I can't get it to idle right.
Did you run this carb before the custom cam install?

Paul
 

·
Registered
Joined
·
2,487 Posts
Did you use the base gasket that came with the carb? Those carbs need that gasket, a normal Holley gasket wilth a spacer will usually result in a vacuum leak.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #7
This carb did run well before the cam swap. It runs well now except for the high idle after driving.

I did swap out the spacer that came with it for a 4-hole phenolic spacer....hmmmm

But I have sprayed starting fluid around the base of the carb with no change in idle.
 

·
Registered
Joined
·
2,982 Posts
what's your timing setup at or what does it measure?



my idle will increase on the order of 200 rpm from complete cold to hot. i attribute that to better fuel atomization with the heat. i don't have a choke.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #9
Timing - I've got a Petronix Billet Ready to Run distributor
Initial is 14d
Total is 34d at about 3200
Vacuum advance is hooked up and works.

I am not too fond of the advance limiting mechanics of the petronix dist. They are arms that float around losely on the weights. My mechanic advance does start to come on right over 1000 rpm, so I expect the high idle and early advance work together to make this worse. Although I have checked the timing during high idle and it really wasn't too high - 16-17 d.

One other important item to add...the high idle does not happen 100% of the time.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #10
I want to post an update.

I have a 71 cheby c10 pickup that has a relatively new edelbrock 600 on it. It has been sitting for a year while I fix the enormous amount of rust on this vehicle. I pulled the carb off.
Drained the yellow/green varinish/gas from the carb.

Placed it in my Mustang - and boom - started right up - 700 rpm idle without any adjustments. Drove it and it ran great. I will tune more later.

But..I want my annular fuel booster cake and eat it to.. How can I get this summit carb to work?
 

·
Registered
Joined
·
2,487 Posts
Since it's off turn it over and stick a base gasket on it. Make sure there are no leaks at the perimeter and also make sure the linkage isn't binding and that the throttle plates are evenly closed
 

·
Registered
Joined
·
4,080 Posts
I want to post an update.

I have a 71 cheby c10 pickup that has a relatively new edelbrock 600 on it. It has been sitting for a year while I fix the enormous amount of rust on this vehicle. I pulled the carb off.
Drained the yellow/green varinish/gas from the carb.

Placed it in my Mustang - and boom - started right up - 700 rpm idle without any adjustments. Drove it and it ran great. I will tune more later.

But..I want my annular fuel booster cake and eat it to.. How can I get this summit carb to work?
This isn't meant to be smart-*** but I'd say to call Summit and talk to one of their techs.


Sent from my iPad using Tapatalk HD
 

·
Registered
Joined
·
106 Posts
Did you verify your choke idle advance is working properly?
Like i said before if your choke butterfly isnt opening properly it will keep it from releasing consistently. I had tightened my air cleaner down to tight and it made the butterfly stick and the idle was intermittently high.
I want to post an update.

I have a 71 cheby c10 pickup that has a relatively new edelbrock 600 on it. It has been sitting for a year while I fix the enormous amount of rust on this vehicle. I pulled the carb off.
Drained the yellow/green varinish/gas from the carb.

Placed it in my Mustang - and boom - started right up - 700 rpm idle without any adjustments. Drove it and it ran great. I will tune more later.

But..I want my annular fuel booster cake and eat it to.. How can I get this summit carb to work?
 
1 - 13 of 13 Posts
Top