Vintage Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Need help with duraspark ignition. I was setting ignition timing tonight on my 67 mustang and noticed the strobe blacks out every couple seconds wondering is this normal or do I have the beginnings of some kind of short. The car hasn't died yet or seemed to act up any one seen this with the duraspark before?

Thanks for any help
 

·
Gone but never forgetten
Joined
·
25,239 Posts
I get the same thing with my MSD. The cause, however, has nothing to do with the igntion ... it's a short in your timing light ;)

Yes, after 20+ years of quality service my Sun timing light is finally showing it's age, and it sounds like yours is too. If the timing light is accurate, the car would die or at least come EXTREMELY close to it when the timing light "blacks out".
 

·
Registered
Joined
·
471 Posts
my old snap-on one does the same thing it's 17 years old one of the first digital ones. ::
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Thanks I'm going to try it out on another car should have thought of that first went through the wiring today took out all the wire connectors and soldered everything back together but I needed to do that anyway.
 

·
Registered
Joined
·
270 Posts
Just a thought if it is your timing light - mine was doing the same and I found the neon :):) globe was faulty, one of the end metal contacts had become loose, it is replaceable but I have wedged it in securely for the moment and will get around to replacing it soon.
 
1 - 5 of 5 Posts
Top