Vintage Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
314 Posts
Discussion Starter #1
My car drives great PLENTY of power but after a couple hundred miles will start to run rough. Pull the plugs and they are covered in carbon, not oily. Do I need to run a hotter plug or change/upgrade my duraspark ignition to an MSD (which gives me an excuse to buy one) or what else could it be? The engine only has like 1K miles.
 

·
Registered
Joined
·
4,747 Posts
Sounds like you are running rich. Might be as simple as a carb adjustment.
 
G

·
Guest
Joined
·
0 Posts
sounds like your running rich. you should be able to chec your spark with an old plug hooked to a plug wire and resting on the manifold.
 

·
Registered
Joined
·
314 Posts
Discussion Starter #4
Any idea how to adjust mixture on a edelbrock 600 cfm carb? Far as I know the only adjustment possible is the idle adj screws...
 

·
Registered
Joined
·
3,595 Posts
The air mixture screws only affect the idle. To lean the carb, you must replace the jets with smaller ones.

Look at the brand and numbers on your present plugs. Then, call the auto parts store and ask them what number for that brand of plug your car is supposed to have. If your number is different from the one they recommend, ask them if yours is a colder, or hotter, than it's supposed to have. If your present plugs are colder, I'd put the recommended heat range plug in the car and see how it runs before fooling around with jets.

Adding an MSD isn't the way to address this problem. Fix the symptom, then you can install an MSD if you want. ::
 
1 - 5 of 5 Posts
Top