Vintage Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I just installed a set of led tail lights from Speedway Motors on my '66. The running lights work fine, the brake lights fine, but not the directionals. Turn the lever and the tail light stays on bright but does not flash. Any suggestions? Thanks
 

·
Registered
Joined
·
1,416 Posts
I just installed a set of led tail lights from Speedway Motors on my '66. The running lights work fine, the brake lights fine, but not the directionals. Turn the lever and the tail light stays on bright but does not flash. Any suggestions? Thanks
I believe you need a different flasher module to make LEDs work for directional. Did the kit come with one?
 

·
Registered
Joined
·
1,172 Posts
I will be interested to hear your resolution. Are these the new ones that have the LED's set right into the lens? I ordered a pair through Virginia Classic but also saw them a few other places. I'm guessing the flasher could be the issue? I won't have my car back together for a year or so most likely.
 

·
Registered
Joined
·
1,172 Posts

·
Registered
Joined
·
1,377 Posts
I believe you need a different flasher module to make LEDs work for directional. Did the kit come with one?
+1. I bought mine from Mustang Project. I actually converted both flashers to be compatible with LEDs as I run the entire car with LEDs. If you still want to hear the click with the turn signals then you have to buy the one specified with the click option.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
Thanks All -

I just ordered the flasher from Virginia Mustang. I'll be back if it doesn't work :)
 
1 - 8 of 8 Posts
Top