Vintage Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
655 Posts
Discussion Starter #1
Here's the original post as a refresher.Started the car to take it to the tranny doctor & reverse was back! But not for long.After a 1/2 hr drive, it was gone again!
Dropped the valve body & the low reverse band did adjust up tight,however the strut, opposite the adjusting nut, was hard up against the case.
Ian reckons there could be a problem with the L/Rev servo piston or stem,(Sound feasible?) but he did'nt have a cover seal & we could'nt immobilise the car.More next week......
Regards Greg
 

·
Registered
Joined
·
952 Posts
I just had my tranny rebuilt. Cost me $777 bucks but that included the torque converter, shift kit, new tranny mount and a new flex plate. Shifting is much more noticable but I understand that comes with the shift kit that was installed.

Should have done it years ago!
 

·
Registered
Joined
·
10,587 Posts
Did you guys try air testing the low-reverse band acutator? One of the two ports in the area of the actuator is for application, the other is for retraction...

The piston has a molded-on seal and IIRC, the whole unit is one piece so, unless it broke, I can't imagine what would've changed, other than the seal wearing out..

When reverse re-appeared, did you try manual low as a cross-check?
 

·
Registered
Joined
·
655 Posts
Discussion Starter #4
He did'nt try the air on the actuator,but when we get to it next week I'll suggest it.
When I had reverse I did have compression bracking in manual low & I just now went for a spin around the block & had all the gears.
On top of this, I now have a vacuum leak so we'll be kitting the Holley & finding the culprit before we get into the tranny!
I'll keep you posted,Pat.
BTW I checked the '69 Servo in the service manual & it shows the L/Rev servo can be dissasembled.Ian says all the pistons he's serviced are one piece units,similar to the intermediate servo's.Must be an Aussie thing!
Greg
 
G

·
Guest
Joined
·
0 Posts
This is exactly what happened to our car 2 weeks ago. The bands were gone and transmission ending up being rebuilt.
 
1 - 5 of 5 Posts
Top