Vintage Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
ok, I'm hoping i can get some assistance here. about 3 weeks back I drove my 69 Mach1 mustang and noticed NO turn signals on the dash lights. when I got home I checked the front lights and and rear lights. I had turn signals in the front but nothing in the back lights. I pulled the bulbs wishing it was just that but NO, they all were fine. I changed out the flashers and my emergency flasher is working and lighting only the front lights, nothing in the back. And NO turn signals at all now; front or back. I bought new flashers and installed, again no turn signals NOW in the front or rear, BUT, the emergency flasher is working in the front only. I then changed out the turn signal switch and nothing has changed. Also I noticed I'm not getting any clicking on the turn signal flasher at all. I've checked all the grounds I can find and they all seem good, I'm wondering if I'm not getting power to the turn signal flasher since it's not clicking at all. Can anyone offer suggestions as to what and where to check?? Can anyone tell me where I can find the wiring diagram to this years car??thanks, Morrie
 

·
Registered
Joined
·
5,737 Posts
ok, I'm hoping i can get some assistance here. about 3 weeks back I drove my 69 Mach1 mustang and noticed NO turn signals on the dash lights. when I got home I checked the front lights and and rear lights. I had turn signals in the front but nothing in the back lights. I pulled the bulbs wishing it was just that but NO, they all were fine. I changed out the flashers and my emergency flasher is working and lighting only the front lights, nothing in the back. And NO turn signals at all now; front or back. I bought new flashers and installed, again no turn signals NOW in the front or rear, BUT, the emergency flasher is working in the front only. I then changed out the turn signal switch and nothing has changed. Also I noticed I'm not getting any clicking on the turn signal flasher at all. I've checked all the grounds I can find and they all seem good, I'm wondering if I'm not getting power to the turn signal flasher since it's not clicking at all. Can anyone offer suggestions as to what and where to check?? Can anyone tell me where I can find the wiring diagram to this years car??thanks, Morrie
Morrie,
Do your brake lights work?

Keep in mind the TSs only work with the ignition switch in ON or ACCY.

I dont have access to 1969 Wiring diagrams. What is the color codes of the two wires at the TS flasher? (example for 68 they are ORG/YEL and BLU).

Test: disconnect the TS flasher and install a jumper wire (ie paper clip, etc) between the wires at the flasher harness connector. Turn the ignition switch ON and try the TSs. Do any lamps light?

Paul
 

·
Registered
Joined
·
35,311 Posts
IIRC, the indicator lamps branch off the front turn signal lamp circuit so if the front turn signals are flashing (when the hazards are working) and the indicator lamps are NOT flashing then either both bulbs are blown or the turn signal switch wiring is messed up. I have heard some cases of mismatches in the plugs. I'd grab the wiring diagrams (Google "69 Mustang wiring diagram" and find the appropriate image) and start looking at the pin assignments.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #4
Yes Paul, I had my ignition turned on. I do have brake lights and running lights in teh rear, but no flasher or turn signals in the rear lights.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #5
the front lights flash with the emergency button is depressed but they do not flash on turn signals. I've just replaced teh turn signal switch and have the same results.
 

·
Registered
Joined
·
79 Posts
What resistance do you get from socket housing ground to the body? I had similar issue and had continuity but high resistance. Cleaned grounds and used new screws and all is good.
 
1 - 7 of 7 Posts
Top