Vintage Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
I am having trouble getting my I6 enigne to turn over. The car had been sitting for a while and when I went to start it nothing happened i charged the battery, replaced the starter solenoid and the starter motor. After alll that when i turn the key the engine turns but will not run. I have no idea what to do now any help would be appreciated. thanks in advance
 

·
Registered
Joined
·
846 Posts
Are you getting fuel to the carb? How about fire from the plugs and coil?
 

·
Registered
Joined
·
29 Posts
Discussion Starter #4
I think it is the 4.2 liter inline 6. I am not sure if it is getting a spark because i took the plug off the center of the distributor cap and it was green and breoken so I replaced it. But it still didn't work. Should i put some gas in the carb and see if that works. The car had been sitting for a while. Thanks
 

·
Registered
Joined
·
21,329 Posts
We use to own a '89 Cherokee. Every so often with out warning, you couldn't start it. You could have just shut it off 5 minutes ago and then it wouldn't light off. The problem would always be the crankshaft posistion sensor that reads the flywheel on the driver's side going bad. Not expensive but a pain to change.

Luckily, most of the time when the darn thing went bad, the car was in my driveway except once...how's that for luck. I must of changed it 3 or 4 times!
 

·
Registered
Joined
·
37,647 Posts
If it's the 4.2 liter (258-carb), spray some carburetor cleaner down the carb and make sure the choke is closed. Better yet, make sure the air cleaner element and housing is installed (Read about house fire in post farther down the page). If it fires up, and you do this a few times and it's still not running, check fuel line at pump to see if fuel present from tank line. Check filter also.
 
1 - 7 of 7 Posts
Top