Vintage Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,209 Posts
Discussion Starter #1
i put in a new t/s switch,,,second one, now everything works but my brake lights, and when i try to jumper the brake light switch with a jumper wire ,it sparks,starts to get hot and my headlight switch starts making noise, did i get another crappy turn signal switch... :: second one[/b]
 

·
Registered
Joined
·
10,587 Posts
Time to blow up a wiring diagram and tack it to the wall and troubleshoot your electrical system....it's something simple but buried, I'll bet.

Randy can elaborate but I've found starting at the beginning and working one's way slowly through all the circuits usually yields results. I troubleshoot 3 phase mostly so using jumper wires is contra-indicated *G*. Get to know and believe in your VOM.

Keep us posted on your progress...
 

·
Registered
Joined
·
1,209 Posts
Discussion Starter #3
ihave already checked my whole system before, would jumpering the wiring to the brake light switch ,with the sparking and heating up tell me that its shorting out in the t/s switch??
 

·
Registered
Joined
·
10,587 Posts
What happens when jumping the brake light switch if you seperate the two -conductor plug at the turn signal switch which has the orange/blue and green/orange wires emminating from it?
 

·
Registered
Joined
·
1,209 Posts
Discussion Starter #5
when jumping the brake light switch,the two female connectors on the plug ,should light up the brakes whether the brake light switch is good or not but mine is sparking when i jump it,??
 

·
Registered
Joined
·
10,587 Posts
The idea I suggested isolates the turn signal switch and takes the brake lights and their wiring out of the loop. If the problem goes away, then the issues are with the brake light wiring. If it remains, the problem is between the brake light switch and turn signal switch, including the switches themselves.

I'm far from the electrical guru here....hopefully Randy or one of them will stop by and help out...
 

·
Registered
Joined
·
1,209 Posts
Discussion Starter #7
ok problem almost fixed one more time, i took out the t/s switch, the solid green wire was crimped with wire showing.i hooked it all back up outside the column and it all works,now the problem is that since it shorted out it partially melted my brake light switch...i love this hobby. thanks to all that replied,, ill be back... ::
 

·
Premium Member
Joined
·
19,169 Posts
Gotta be very careful with wires in small, cramped areas. Did you put black electrical tape on the back of the turn signal switch (where it might contact the steering column) like I told you?
 
1 - 8 of 8 Posts
Top