Vintage Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
330 Posts
Discussion Starter #1
I have finally got my fan installed and have one more question. What size fuse is standard? A 20 amp blows on start up but a 25 amp does not. Should I stick with the 25 or go to a 30? Ihave cycled this thing about a dozen times on and off with the adjustable thermostat and all seems well. The specs says it will draw 11 amps running but not what size fuse to use. As usual, thanks for your answers.
 
G

·
Guest
Joined
·
0 Posts
Based on empirical evidence, I would probably go with the 25 amp fuse. However, it seems suspicious to me that it blew a 20, it really shouldn't have. Did you try more than 1 20 amp fuse? Mighta been a bad one.
 

·
Registered
Joined
·
330 Posts
Discussion Starter #4
I do indeed have an upgraded alternator. I also went thru 3 20 amp fuses before trying the 25.It seems to have a surge at start up and then draw less amps when running. I just wondered if this was normal on the Spal fans.
 

·
Registered
Joined
·
1,076 Posts
It's normal for any electric motor to draw a higher current during startup (it's called inrush current). Depending on the type and size of the motor it can sometimes be several times the running current. In some applications a slow blow fuse is used. Check with the manufacturer, maybe you are not using the proper fuse. If you are using their recommended fuse and are still having problems, then the fan may be bad (possible shorted winding). Hope this helps.

Lou
 
1 - 6 of 6 Posts
Top