Vintage Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,725 Posts
Discussion Starter #1
Both my park lights and turn signals quit today. Is there a common fuse or breaker for those on a 65??
 

·
Registered
Joined
·
5,737 Posts
Did you loose parking lights in front as well as rear? IF you only lost everything in rear I'd check connector at driver side kick panel. If ok then follow it back rear making sure no damage. As said two diff fuses however you may also have dirty contacts at fuse block. Make sure using meter you have 12 volts on both sides of fuse. Verify it across fuse holder itself, then across the fuse itself.
 

·
Registered
Joined
·
1,725 Posts
Discussion Starter #4
lost the front park lights and both front & rear turnsignals, Still have brakelights and tail lights on both sides.
 

·
Registered
Joined
·
1,725 Posts
Discussion Starter #5
Is the problem in the headlight switch?
 

·
Registered
Joined
·
5,737 Posts
So you have rear tail lights (running lights) and rear brake light but NO turn signal lights in rear or front. But nothing up front. The rears may not blink because fronts are out so I doubt problem in rear. I doubt a fuse. I'd lean more towards a bad connection somwhere, maybe at firewall where harness goes thru I think. If you had just no front lights I'd say h/l sw or if just no t/s lights I'd say t/s sw or flasher but you have neither up front only, a bad connection. Make sure both front bulbs good. Then follow harnss for front lights to see if if pinched, cut or bad connector. Always check basic things before spending silly money.
 

·
Registered
Joined
·
1,725 Posts
Discussion Starter #7
Thanks guys. I'll take a closer look at everything after work today.
 

·
Registered
Joined
·
1,725 Posts
Discussion Starter #8
OK guys, I really need some help here. I've lookad at everything I can think of and still no park lights or turn signals.
I have a wiring diagram but it's really hard to read.
Where do these get their power from? The headlight switch? Could it be the switch or maybe a connector came off at the switch. They were working when the car came back from the paint shop then just quit.
I have checked all the connections at the lights on both sides.
 

·
Registered
Joined
·
1,725 Posts
Discussion Starter #9
BTW, I know I have no power to the park lights. Can the main plug at the firewall be unplugged to see if I have power to that point?
 

·
Registered
Joined
·
5,737 Posts
I have the '67 in pics but also have a '66 vert in process that I haven't touch in awhile as well as have stripped out a few '66 car. IIRC the '66 has a conn @ firewall somewhere above column. Ones I've seen have had corroded connectors. Look at the wire colors at front parking lights and find it at firewall. At firewall measure for 12v. If you have 12v at firewall them prob in frt harness, if not prob inside car. But my guess (not being there) is with 2 diff circuits out for 2 diff front lights, it's gotta be a cut,pinched, or corroded connection.
 

·
Registered
Joined
·
35,866 Posts
If all quit at the same time, you're wasting your time checking the lamps. Your problem is under the dash. Do you have a test lamp?
 

·
Registered
Joined
·
215 Posts
If all quit at the same time, you're wasting your time checking the lamps. Your problem is under the dash. Do you have a test lamp?

I am a noobie but I thought all the power for these lights went through the turn signal switch as well.
 

·
Registered
Joined
·
1,725 Posts
Discussion Starter #13
Guess what??? When I went to start the car, the battery was down. As soon as I hooked up the charger, the park lights started working. The turn signals still do not work, but I have the LED sequentials and I hope when voltage gets up more they will work too. I'll keep you posted as to my STUPIDITY. I have been chasing these demons all day & then find out it's low voltage.
 

·
Registered
Joined
·
5,737 Posts
I am a noobie but I thought all the power for these lights went through the turn signal switch as well.
Running lights or "parking lights" as some call would not go thru t/s switch as it has nothing to do with lights that wouldn't normal blink. Those lights would go thru H/L switch as it's a seperate circuit. Brake lights, T/S lights & cars with factory hazard lights go thru T/S switch.
 
1 - 14 of 14 Posts
Top