Vintage Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,106 Posts
Discussion Starter #1
Got my 66 fastback home last week and pictures are in. Over the long weekend I installed the 5.0 roller cam motor and T5. Hope to get her running by the end of this week!

Photos are at: home.netcom.com/~cmathes/mustang_photo.html
Let me know what you think. Note, some of the photos are large, I have not made thumbnails yet.
 

·
Registered
Joined
·
143 Posts
I like the color. What tire/wheel combo are you running? Did you get the 5.0 from Ford or have it custom built? Great looking car.
 

·
Registered
Joined
·
771 Posts
looks good, your sons look like they will be future mustangers good luck on the project and nice work. Is that a mach 1 hood in the bacground of that one pic?
 

·
Registered
Joined
·
1,106 Posts
Discussion Starter #4
Thanks for the kind words. I think the hood is original 66 but is very rough. The PO cut a very rough hole that looks like it was cut with a hack saw and hammer, then epoxied an off brand scoop to it. Not sure if it is usable. The motor and trans are from an 85 GT that I had custom built. The heads are large chamber with over sized valves with port and polish. And I have a 1.88:1 rod ratio. Looking forward to the dyno session that I hope to have in a couple of weeks.
 

·
Premium Member
Joined
·
3,637 Posts
Nice stuff. I'm also doing restomod on 66 FB A code Auto to 347 Stroker W/Tremec 3550. It's nice to see a light at the end of someones tunnel even if it's not mine. Enjoy!
 
1 - 6 of 6 Posts
Top