Vintage Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6,630 Posts
Discussion Starter #1
taking a look at the motor mounts at http://www.mustangmonthly.com/techarticles/39446/index29.html

It looks like one could cut the rubber along the frame side plate, flip the plate 180' and use 2 or 3 grade 8 bolts to hold it in a semi-solid configuration, then it would bolt up to a 67 just fine. Think it would work?
 

·
Registered
Joined
·
81 Posts
If you pick up a pair of frame brackets from a 68 it will bolt right up, then you can use the plentiful motor mount insulators from 64.5-66 and 68-70 and problem forever solved searching for the 67 mounts (which are different then every other year mustang dimensionally and geometricly). I managed to make the ones that MU sent me (wrong ones) work by playing with the tranny mount to adjust to the mounts making the motor sit 1/4 inch forward then the 67 mounts would have it sit. Guess we shall see what happens when i bolt in the driveline and run the motor for the first time. Incidently I managed to break my LH side mount last night when i pulled the new ones off to fit the originals back on for testing. Pulling a motor and swapping the mounts twice by myself without help was a major PITA, but worth it, as its all bolted in now, and ready for the ride to Texas....
Good luck, let me know what you come up with. As I have to replace the broken mount anyways, I would be able to possibly use your solution as well...

-A.J.
 

·
Registered
Joined
·
531 Posts
I read the article you have a link to, and it's a good one, but I need a little more! I have three sets of motor mounts (two sets from 67's and one set pulled from a '68). I only have one one set of frame brackets removed from the '67 I am restoring. I didn't know '67 was an odd year, so I took the mounts off the bracket and threw them in the pile with the rest. After this post, I went to check which ones I have. Yikes, they all look identical, and I can't read markings or castings on any of them. How can I tell which mounts I have, and which frame brackets I have? Is there a good site identifying the differences? Could the '68 mounts have been incorrectly used by the PO, or maybe it was converted to the '68 brackets... DUNNO!!!!

Any help would be appreciated....
 
1 - 5 of 5 Posts
Top