Vintage Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I am putting back together a 1970 Mustang Mach 1 w/ PS and I am having some problems with the PS.
With the front end up on jacks it seems to turn both ways well, but it seems want to creep/turn to the right in slow motion. You can watch the steering wheel move to the right slowly.
Then when driving it tends to pull to the left. This happens sometimes during driving and always during braking. Sometimes the car will drive straight without any pulling what so ever.
Now when I try to compensate for the pulling left while driving sometimes it will suddenly jerk to the right and I have to try and regain control quickly.
Per the shop I had do the alignment, it is within factory specs for alignment.
Any ideas on the problem?
Thanks.
jlundqu
 

·
Registered
Joined
·
1,447 Posts
Just curious - did you have the two small hoses off the ram underneath the car? It sounds like they may be switched. The can very easily be put in the wrong order. Try switching them, and let us know what happens. Tony
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
I was thinking the same thing initially, when I swapped them to test it really didn't work, the wheel could break your hand it turned so quickly. So I believe they are connected correctly.
In the control valve, is the long bolt that runs the entire length of the valve supposed to move back and forth at all?
Could the steering gear box be at fault?
Thanks for any and all help.
jlundqu
 
1 - 4 of 4 Posts
Top