Vintage Mustang Forums banner

21 - 29 of 29 Posts

·
Registered
Joined
·
2,450 Posts
I have only had my system on for a couple months so far, I have the TCP power rack and the KRC pump with integral reservoir. I do not have any noises under normal circumstances but I do when ever I get to full lock in either direction - it makes kind of nasty squeal noise.

I had the car on the track for a few sessions last week and didn't experience any issues with noise or foaming of the fluid. I am using the NAPA brand power steering fluid which is what I believe was specifically recommended to me somewhere along the way as it has different properties then some of the other chain store non-synthetic brands.
Do you have the street pump or track/performance pump? I am using a remote reservoir on my system
 

·
Registered
Joined
·
867 Posts
Do you have the street pump or track/performance pump? I am using a remote reservoir on my system
This is the one I bought directly from Summit, I believe its the street pump. FWIW at that track day, I was beating on the car fairly hard with repeated sustained 6000+ RPM stretches on the straights (choose to stay in 3rd gear one session). Although my crank pulley is not stock, it's slightly under driven as they recommend.

https://www.summitracing.com/parts/krs-krc50010100
 

·
Registered
Joined
·
2,450 Posts
This is the one I bought directly from Summit, I believe its the street pump. FWIW at that track day, I was beating on the car fairly hard with repeated sustained 6000+ RPM stretches on the straights (choose to stay in 3rd gear one session). Although my crank pulley is not stock, it's slightly under driven as they recommend.

https://www.summitracing.com/parts/krs-krc50010100
It looks like the higher performance version of the pump, I think mine is the lesser version. I topped up the fluid today but didn't drive it too much. It is a little less noisy with the KRC fluid. I topped up the reservoir almost full, so we'll see how it goes
 

·
Registered
Joined
·
2,167 Posts
I just finishing the swap to a TCP rack. I used an older GM style pump but the car felt twitchy at highway speeds. I figured the pressure was today high.

I swapped in a KrC pump and fluid and the car feels better but I am experiencing the same groan you guys are. I have an attached reservoir and filled the system up to where the tank narrows by the cap. I am seeing bouncing in my fluid. I am hoping it is a bleeding issue and will quiet down as I drive it more. Has a cooler helped quiet down your cars?

After spending the kind of money I just did this is pretty frustrating. I just want to drive the car without it moaning at me.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,167 Posts
I put my car up on my lift to locate a leak that started after my drive and to check for hose issues that could be causing the noisy pump. When I got it up in the air everything looked good. When I looked a little deeper I noticed the center section of the rack had a lot of play in it. It wasn’t that way when I installed it. Has anyone else had that issue?



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,450 Posts
I've been having issues with my TCP R&P in that the system has been making a lot of noise. ....
Any help is appreciated.
I put my car up on my lift to locate a leak that started after my drive and to check for hose issues that could be causing the noisy pump.

I just wanted to update, after switching to the CFV Serpentine system. This system comes with it's own GM style pump. At the time of the switchover, I added an inline PS cooler. Obviously more bends and fittings. Possibly a less refined pump.

Anyhow after driving a few times, I would say the noise is much better (not gone.) It's about 60% of what it was. The serpentine system eliminates the slippage that a v-belt would have had.

To do it again, I'd add an even larger PS cooler.

I may send the KRC pump back to get rebuilt and add the proper pulley for the serpentine system. The stock GM style pump seems to work just fine.
 

·
Registered
Joined
·
762 Posts
Discussion Starter #27
That’s great to hear. After I get my new motor in I’m going to play around and see what I can do. I might adjust the pulley size a bit but I’m glad there’s a solution.
 

·
Registered
Joined
·
2,167 Posts
Thanks for the update. I solved my problem as well. I sold my car and picked up a Jeep Wrangler Rubicon. Now I am working on a totally different set of issues. LOL!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,153 Posts
The two things that really helped quiet my KRC pump down was to mount the KRC remote reservoir up as high as possible and to fill up that reservoir to within 1.25" from the top.

743575
 
21 - 29 of 29 Posts
Top