Vintage Mustang Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 11 of 11 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hello everyone. I would like to see if anyone has a intermitent Rally Pak tachometer issue. So my rally pac is acting up some. It works for a little during first 15 min of a drive than cuts out down to zero. Next drive it will do the same. anyone experience this. Mine is a original and still works from the positive from the ignition. Thanks for looking.
 

·
Registered
Joined
·
7 Posts
Not sure if it pertains to your original Pac or not, but I've had the same issue with a Scott Drake repro. For me, just tapping the side of the tach brings it back to life.
 

·
Registered
Joined
·
2,256 Posts
Had this issue - found a loose ground (broken) wire.

John
 

·
Registered
Joined
·
1,158 Posts
I rewired mine. Pretty simple. Sent out my clock for repair and now both work great.

I'd start with pulling the wiring apart and checking it.
 

·
Registered
Joined
·
1,178 Posts
Hello everyone. I would like to see if anyone has a intermitent Rally Pak tachometer issue. So my rally pac is acting up some. It works for a little during first 15 min of a drive than cuts out down to zero. Next drive it will do the same. anyone experience this. Mine is a original and still works from the positive from the ignition. Thanks for looking.
Does the tach and clock both cut out at the same time?
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
No the clock always works and holds time. I feel its in the tach, just havnt taken it apart. want to see if anyone had an issue like this for some direction.
 

·
Premium Member
Joined
·
6,099 Posts
No the clock always works and holds time. I feel its in the tach, just havnt taken it apart. want to see if anyone had an issue like this for some direction.
Yeah that sounds like a bad ground or in the tach itself, because if the whole thing failed, the original wiring is such that the car won't start, I believe.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #11
yes. the car always runs as the ignition wire goes to the tach before the distributor. I'll go thru it all again when I get some time. I feel like it ground issues too.
 
1 - 11 of 11 Posts
Top