Vintage Mustang Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
691 Posts
Discussion Starter #1
So I was trying to run my car down to less then 5 gallons since I have to replace the Fuel sending unit which is on its way here. I have a 67 Stang with the 16 gallon tank. I figured I would be getting at least 12-15mi/gal so around 192mi to the tank or more. But nope ran out of gas at 156mi from last fill to the top, so 9.75mi/gal. Should I be worried about gas mileage? I have a 289, 4v Edelbrock Performer intake, 600cfm Carter carb, Mild cam and a C-4 with 2.79 rear gears. I do mostly city driving not freeway. I read some past posts and people are getting 20mi/gal or more. I do feel my carb is running way too rich but wanted to get your folks thought.
 

·
Registered
Joined
·
691 Posts
Discussion Starter #5
Hmm picture is right side up but when I attached it, it put it sideways. Weird.
 

·
Registered
Joined
·
4,355 Posts
city driving=stop&go
mild cam=less mpg
C4=fewer mpg
2.79 rear = sluggish so you gas it more just to feel normal.
Idling even while coasting adds up

Did you slosh the tank and make sure it picked up 98% of the gas?
 

·
Registered
Joined
·
691 Posts
Discussion Starter #10
Thanks guys. So to answer some of the questions. The plugs are about 3 years old. They are the Bosch Platinum DR8BPX, I usually only put 1-2k miles per year so at the most maybe 6k miles on the plugs. I can't find where I wrote down when I replaced them which I usually do. Ill check the tank once I get the sending unit to see how much gas was left but banging on it sounds pretty empty. It is garage kept, no smell of gas in there only when I turn it on smells a little rich. I did tune the carb idle screws to get the most vacuum which was about 12 last year. Timing is at 12 base, not sure if that matters.
 

·
Registered
Joined
·
3,292 Posts
The dark black ring at the base indicates that it is running just a little too rich. The strap looks a little rough. Possibly old plugs or bad ignition. The porcelain should be a light tan or light gray.
You might need to do a jet change, but running a little rich is better than running lean.
 

·
Registered
Joined
·
2,808 Posts
Your gas mileage sounds a bit right for me, especially since you might be running a tad rich (better than a tad lean) and do mostly city driving. Don't worry about it at all.
 

·
Registered
Joined
·
691 Posts
Discussion Starter #15
Ok. Yeah I do have a heavy foot. My wife and kids say I drive too fast and I don't drive the 67 any differently then my other cars. Just wasn't sure if the 10mi/gallon was a cause for concern or not. I read some past posts about the Copper Autolite plugs being easier on the Ignition system. So maybe Ill go back to stock plugs to see if that helps and I can try a jet change to a leaner setting.
 

·
Registered
Joined
·
6,389 Posts
Huh, 10 mpg sounds very low to me for that engine package. My 289 with stock heads, 4v Offenhauser intake, and fairly hot cam, paired with 3.23 rear gears and a lead foot, still pulls a good 15 mpg in the city. I do have fuel injection now but when I had a Holley carb earlier it still got 15 in the city, so no difference there.

Guess maybe the auto kills your mileage? I can't see it cutting it by 30% but maybe it does.
 
1 - 17 of 17 Posts
Top