Vintage Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,869 Posts
Discussion Starter #1
For the life of me I cannot get the distribtor out of my 390. I've tryed everthing short of useing my pry-bar and it won't budge. Someone help me, please!

Someone please buy my Ski Doo!
68 fastback, 390 4V premium fuel
80 5.0 hatch, just finished
91 5.0 coupe, daily driver
84 RamCharger 4x4 extreme mudsliger and winter junker
 

·
Registered
Joined
·
227 Posts
Take the bolt out first - just kidding - LOL :) There is a rubber o-ring sealing the distributer to the intake manifold. It must be caught up on something. Try rotating the distributor as you pull up. Can't think of anything else that would prevent removal.
 
G

·
Guest
Joined
·
0 Posts
You've failed to mention the specifics. Does it rise at all? Does the housing rotate? Has there been any catastrophic damage in the engine? I would start at the beginning, i.e. pulling real hard, followed by hitting it with a wooden mallet. If that doesn't work, you'll have to find where it's binding. I would attempt to pull the intake manifold (you're probably due for a new gasket anyway). Next, I would pull the oil pan, oil pump, and shaft (perhaps there is bind). If all this fails, the seizure is probably due to binding caused by odd wearing between the cam and distributor gears. At that point I guess I'd try and push the cam back and slightly separate the gears (if possible). Lastly, I'd throw it away and by an SVO stroker big block. Maybe you should just leave it be and replace the points.......
 

·
Registered
Joined
·
1,869 Posts
Discussion Starter #5
Distributor has to come out to get the intake off. Stupid, stupid design!

Someone please buy my Ski Doo!
68 fastback, 390 4V premium fuel
80 5.0 hatch, just finished
91 5.0 coupe, daily driver
84 RamCharger 4x4 extreme mudsliger and winter junker
 

·
Registered
Joined
·
1,135 Posts
I had the same problem. Mine would not budge or turn or anything. It was just severely gummed up with 36 years of crap. I sprayed some PB Blaster around the base a few times and let it sit for a few minutes and it poped right out. WD-40 might work also. Good luck

AKA "Fastbackpimp"
[color:blue]65 Fastback</font color=blue>
http://hometown.aol.com//dasbus73/Index.html
[color:blue]VMF Member Since Nov. 99</font color=blue>

http://members.aol.com/_ht_a/dasbus73/65fbjackstand1.jpg
 
1 - 6 of 6 Posts
Top