Vintage Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
my 65 restored mustang keeps running out of gas and when I put gas in, it takes a couple gallons and gas gushes back out at me. We changed the sending unit, but there is still something else wrong. any ideas ?
 

·
Registered
Joined
·
1,170 Posts
From what you describe the tank is not vented or the gas cap is not vented. If the car runs for a while and then quits, and starts to run again after opening the gas cap you have a vent issue. What happens is that your fuel pump is creating a vacuum in your tank, which leads to the gas going to the carb. But after awhile w/o any new air coming in the tank the pressure equalizes, then the tank starts to have negative pressure, and the fuel pump can't draw any more fuel. If you open the gas cap, and you either get splashed with gas or hear a sucking sound you have a vent problem. Get a vented gas cap.


Is what I described happening or is it something else?
 

·
Registered
Joined
·
2,658 Posts
Just drove home my new-purchase '66. It's a C-code still equipped with the Autolite 2V. Runs like a sick dog. No skipping or noise, just weak. Stopped to add fuel on the way home and the tank sucked air strongly when I removed the cap. Seems like there is a plunger in the fuel cap. How to test if the cap is venting? Stock fuel cap.
 

·
Registered
Joined
·
273 Posts
Just drove home my new-purchase '66. It's a C-code still equipped with the Autolite 2V. Runs like a sick dog. No skipping or noise, just weak. Stopped to add fuel on the way home and the tank sucked air strongly when I removed the cap. Seems like there is a plunger in the fuel cap. How to test if the cap is venting? Stock fuel cap.
Hope it wasn't the gas cap that made the sale happen, jk.
 

·
Registered
Joined
·
2,658 Posts
Hope it wasn't the gas cap that made the sale happen, jk.

No, LOL! As a matter of fact that cap will be history as I much prefer the '65 cap. As far as the purchase goes, it was the overall condition, the Classic Auto Air system and the SSBC front discs. As per SWMBO, it was the a/c.
 

·
VMF Ambassador
Joined
·
6,589 Posts
See if it'll run with the gas cap off. If so, then you know the problem is limited to your gas cap (likely not venting).
 
1 - 7 of 7 Posts
Top