Vintage Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
602 Posts
Discussion Starter #1
I took my ‘66 out for a ride today and on the way home,we were running then pretty hard. On the final leg, I ran her up to 5,000 rpms or so and the smoke started. She smoked a couple of minutes and cleared up. Looking under the car, there are signs of transmission fluid on the exhaust pipes toward the tail shave, but I don’t see and signs of where it came from. I changed the pan and gasket last month and haven’t driven her since. She was a quart and a half low. Like I said, I know I lost some fluid, but I’m also wondering if iT was full.

Any suggestions of odd places for a high rpm leak? The odd thing is that she’s shifting fine. I’m puzzled
 

·
Registered
Joined
·
2,096 Posts
Last time I blew up a C4, the bushing spun around the input shaft and tore up the seal, messed up the front pump...did a rebuild and got a balanced converter and a new transmission mount, greatly improved noise,vibration and harshness. I kind of wished I had gone ahead and put in an aod at the time so I would have OverDrive now
 

·
Registered
Joined
·
602 Posts
Discussion Starter #4
Last time I blew up a C4, the bushing spun around the input shaft and tore up the seal, messed up the front pump...did a rebuild and got a balanced converter and a new transmission mount, greatly improved noise,vibration and harshness. I kind of wished I had gone ahead and put in an aod at the time so I would have OverDrive now
If she blows, that’s exactly what I’m planning to do 3.80 gears without overdrive is tough
 

·
Administrator
Joined
·
19,644 Posts
Sounds like it may have been overfilled. When revved up and hot, overfilled transmissions have been known to dribble out the vent just as you describe. On vehicles the age of ours there is no guarantee that the transmission dipstick is the original or correct. I've definitely been bitten by that issue.
 

·
Registered
Joined
·
602 Posts
Discussion Starter #6
Sounds like it may have been overfilled. When revved up and hot, overfilled transmissions have been known to dribble out the vent just as you describe. On vehicles the age of ours there is no guarantee that the transmission dipstick is the original or correct. I've definitely been bitten by that issue.
I have a Lokar dip stick. I has leaked in the past. Thank you for the reminder. Sounds like I need to investigate there
 

·
Registered
Joined
·
3,198 Posts
I had the exact same problem with my rebuilt C4 with the 331 in the car but not when I had the 289, even after my thrust bearing issues were solved. Seemed it was OK with 200 HP but not 300+. It would show up halfway through second gear while doing 1/4 mile type passes. Shifted and ran fine with no sighs of slippage and all indications showed it was coming from the vent.

I'm curious to know what you find out. I ended up going T-5z. 3.80 gears with a C4 is not my cup of tea as I couldn't stand 3.40 gears with my C4. I am a self admitted overdrive loving wuss though. And proud of it!:grin2:
 

·
Registered
Joined
·
544 Posts
Interesting, subscribing. There’s one particular curve when I’m going around it (towards the left) and flooring it, I’ll get some clouds out the back after I get through the curve. Never thought it might be transmission fluid causing the smoke. My C4 runs quite crisp. Let us know what you find out.
 

·
Registered
Joined
·
602 Posts
Discussion Starter #12
Interesting, subscribing. There’s one particular curve when I’m going around it (towards the left) and flooring it, I’ll get some clouds out the back after I get through the curve. Never thought it might be transmission fluid causing the smoke. My C4 runs quite crisp. Let us know what you find out.
Funny thing is that I had just made a leftturn and put her to the floor when it happened. It’s chilly and rainy so I’m hoping to dig in this weekend
 

·
Registered
Joined
·
602 Posts
Discussion Starter #13
I had the exact same problem with my rebuilt C4 with the 331 in the car but not when I had the 289, even after my thrust bearing issues were solved. Seemed it was OK with 200 HP but not 300+. It would show up halfway through second gear while doing 1/4 mile type passes. Shifted and ran fine with no sighs of slippage and all indications showed it was coming from the vent.

I'm curious to know what you find out. I ended up going T-5z. 3.80 gears with a C4 is not my cup of tea as I couldn't stand 3.40 gears with my C4. I am a self admitted overdrive loving wuss though. And proud of it!:grin2:
Im running 3.80 gears in her. I had her rapped pretty good most of the trip. Hope I can figure it out
 
1 - 14 of 14 Posts
Top