Vintage Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter #1
Dumb question, sorry, but I am missing my Spedo cable to firewall rubber seal/grommet. I can't find one listed in the catalogs and the grommet isn't included with a new Spedometer cable for a '64-66 V8 w/C-4.

Where can I find one??
 
G

·
Guest
Joined
·
0 Posts
If it's like a 65/66 car, then it is nothing but a little tube made of closed-cell foam. Not much to it at all. I have never seen them in any catalog, though.
 

·
Registered
Joined
·
129 Posts
Discussion Starter #3
So...what would someone do who wanted to restore their car for concours purposes? There must be some place I could find the right kind of seal or grommet for the firewall where the spedo cable pases.

best,

Drew
 

·
Registered
Joined
·
2,596 Posts
Well, it wouldn't be too difficult to fabricate one. The originals are very crude looking and covered with undercoat as well. That same gloppy undercoat/sealer that they shot all over the firewall (and the blower motor...) had pretty well obscured the seal on both of my 66s. You really couldn't tell what was sealing the hole up until you pulled the cable out.

If you were to take a strip of closed-cell foam (black would be best), wrap it around the cable, glue the ends together, and stuff it in the hole, I doubt anyone would be the wiser. Follow up with some of that undercoat and I supect that even a Gold Card judge (sorry Charles and Jeff *G*) couldn't tell the difference.
 
1 - 4 of 4 Posts
Top