Vintage Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter #1
I drove my vert to work this morning after having the C4 adjusted. after it was swapped into my car I couldn't get reverse to engage and couldn't get it to shift from 2nd to 3rd. After the adjustments reverse worked fine and it did shift, but rather erratically-sometimes at 35 mph, sometimes 45mph, sometimes 50. I drove it around at lunch today and after about 30 minutes 1. it started to get real hot; 2. the reverse stopped working again; and 3. it won't shift from 2nd to 3rd. Why in the world would it have been working and all of a sudden stop like this? My cousin who owns his own shop did the adjustments for me but he is out of town until the weekend so I can't get in touch with him to find out what he did to make it work. He did say something though about the valve body was messed up, and now I am wondering if he meant it was plugged up somehow and it is plugged up again. Any suggestions? PS - also, in swapping from a 3 speed to a C4, should I have gotten a different speedometer cable? I think it is now registering 10 mph too low. Thanks in advance for any and all input. ::
 
G

·
Guest
Joined
·
0 Posts
This what happens when you start "swapping" stuff. At this point I would put the 3-spd back in. If you can't get it back have the C-4 trans benched, rebuilt and installed by a professional resto shop. ::
 

·
Registered
Joined
·
10,587 Posts
After the adjustments reverse worked fine and it did shift, but rather erratically-sometimes at 35 mph, sometimes 45mph, sometimes 50

That sounds wonky. Did your cousin explain what he adjusted?

it started to get real hot; 2. the reverse stopped working again; and 3. it won't shift from 2nd to 3rd.

Hmm...how does the fluid look and smell? When you say reverse stopped working, does that mean the engine just free-revs in reverse? Does it shift OK from 1 to 2?

I wonder if your cousin jacked-up the band adjustment.

Lastly, since this is a swap, what is the C4 out of? If it's not out of a floor shift car, you may have the wrong shift lever and downshift lever for your setup.

Get back to us.....someone else will help you out; I'll be out of town for a week starting tomorrow. PM me if you guys can't get it figured out. I've done this before *G*
 
1 - 3 of 3 Posts
Top