Vintage Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Okay I have a little problem with my tilt colmun on my 1971 Mach 1 here the story:

I tore the colmun down to replace the turnsignal swich all went fine, but something clicked and a spring and something else pop out. Can't find them anywhere I removed the seats and even pulled out the carpet and nothing checked the shop floor, tore my two post lift apart can't find the spring and what ever else it was- have no idea where they are. So I put the colmun back together and now the tilt does not work. you can move the wheel up and down and hear it click. So my question is does anyone know what all parts are lost and if they know where I can get new ones and what did i screw up and how do I fix it? Its my own dumb a## falt for getting in a big hurry to get my brake lights fixed.
 

·
Registered
Joined
·
2,032 Posts
Was it the big spring at the top of the picture? Its pretty big and would be hard to lose. Not sure how far apart you went with it but I think it controls tension on the lever that spring loads the lower locking pawl.
 

Attachments

·
Registered
Joined
·
14 Posts
Discussion Starter #3
No I don't think it was that big, but i dont have any tension on the lever, Is there someone who can rebuild these or a guide to get me into the colmun that deep. I think if i could get into it that far I could maybe see what is going on.
 

·
Registered
Joined
·
2,032 Posts
There's a tiny spring and plastic pin that load the bale. If you pulled the key switch housing then thats probably what fell out. There are a few guys that rebuild them or will have the parts you need. I can PM you their contact info. I am converting a column like yours to use in my 70 Mach 1 and plan to document the conversion.

This is a lousy pic, but pop the plastic turn signal cover door and see if you have the spring in there that contacts the bale. The arrow is pointing at its location.

Also, am curious. Did you have to cut and splice the switch leads or did you fish the plug thru the casting and replace it in one piece?
 

Attachments

·
Registered
Joined
·
14 Posts
Discussion Starter #5
yes thats the spring I lost. I fished all them wires throw the old plug after removing all the old one. This took me three nights to get done. Not a hole lot of fun. Please PM the people name who work on these colmuns. Thank you
 

·
Registered
Joined
·
2,032 Posts
Cool, will PM you their info. So you managed to pull the plug thru complete or you unpinned the plug? Is very difficlult to unpin that plug, if you unpinned it would like to know what tool you used.
 
1 - 6 of 6 Posts
Top