Vintage Mustang Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
I have a C4 tranny that when i'm sitting at idle will slip out of gear and i will hit the gas it will just rev until it kicks into gear. Fluid level is good, and i just replaced the filter 2 weeks ago, no pieces or tranny or excessive metal in the bottom of the pan. Anyone have any suggestions or is the tranny blown?
 

·
Registered
Joined
·
666 Posts
When you replaced the filter did you rember to put the vavle and spring back in, or did they never get noticed??
 

·
Registered
Joined
·
64 Posts
Discussion Starter #3
i never touched them, just dropped older filter out, put new one in and put the pan back on
 

·
Registered
Joined
·
666 Posts
Ahhh, but the filter holds the vavle and spring in. When you pulled the old filter away from the valve body there was a small valve and spring that fell away in a shower of tranny fluid.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #5
actually, i don't ever think i saw one. I'm fairly new at extensive car work so i really didn't know there was supposed to be one.
 

·
Registered
Joined
·
666 Posts
Stand corrected, didnt know of the difference. Usually when someone does a filter change and cant get the trans to shift right its the valve and spring.

Sorry for the scare.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #9
yeah, but it was also shifting poorly before i changed filter. I'm beginnning to think that the tranny is just blown. Though the fluid wasn't burnt or anything like that when i changed it.
 
1 - 9 of 9 Posts
Top