Vintage Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
696 Posts
Discussion Starter #1
I wanted to try a picture post - I am new at this - sorry if it's large.

This is my 65 coupe's engine compartment. I got the car last summer (71K original miles - car came with all service receipts back to 1966 - quite interesting to go through all of them). I still have a long way to go to getting the engine compartment to look good. As you can tell I tackled painting the air cleaner first.

I am a Mustang restoration rookie and I am sure I will be looking for help as I move along. So be on the lookout for more pictures and more questions....

Thanks!

http://www.freeimagehosting.net/204a0cb7c8.jpg
 

·
Registered
Joined
·
1,194 Posts
http://1968fastback.com/65coupe289.jpg
 

·
Registered
Joined
·
696 Posts
Discussion Starter #5
I have those parts (export brace - shock tower covers) off - have sandblasted and repainted them - I am just waiting until I can get to the rest of the engine compartment before putting them back on. Thanks to those who pointed out that I screwed up the link and those who helped to correct it - I saw a post the other day for the Doofus Award - guess I am in the running now - thanks! If you look at the whole chain here in Flat mode, you can see the shot of the engine compartment. If I get real brave, I will try to post my first shot of engine compartment (when I bought the car - I have actually made some progress).

Notice the shabby wiring heading down by the power steering pump (to the oil pressure sender - or is it the water temp sender?) - is that wiring harness difficult to replace?

Also notice how prior work mounted the washer pump - at least the new decal will cover the holes, right?
 
1 - 5 of 5 Posts
Top