Vintage Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
325 Posts
Discussion Starter #1
Hi everyone I had a broken turn signal switch in my 68 mustang. I purchased a used one but it had two extra wires compared to the original one I had. my breaklights , horn and hazards all work fine but when I put on the turn signals nothing happens,.... no blinking, no constant light. I have no idea where theese extra wires came from but they are seperate from the horseshoe shapped connector, the wires are a brown one and a yellow one with a brown stripe on it. I guess my question is whether or not I have a proper turn signal switch I am not sure if the switches from a tilt column would have theese two extra wires, or if maybe this is from another year/model of ford car?

Any info would be greatly appreciated
Thanks
 

·
Registered
Joined
·
804 Posts
Try checking your fuses. That is always the first place to go for checking out electrical issues. Remember, start simple and move on to the more complicated fixes. Right now I'm gonna check an electrical schematic and see what those other two wires are for. Later.
 

·
Registered
Joined
·
6,008 Posts
Sounds like it could be from 65-66. They definitely had two extra wires that went to a separate connector, which in turn went to the rear turn signals. Sounds like you have an open circuit (no blinka blinka sound from the flasher?). If so it is most probably due to the fact that that those two extra wires do not terminate anywhere.

That's my guess.

Frank
 

·
Registered
Joined
·
354 Posts
I actually have three extra wires - the two you mentioned plus a red one. The mustang shop I bought it from said these switches are built to fit more than one model and to just cut off the extra wires. I did and everything worked fine. ::

Check all the other stuff - flashers, grounds and bulbs. A voltmeter would probably help isolate the problem quickly.
 

·
Registered
Joined
·
804 Posts
Checked the '68 Wiring Schematic Manual, didn't find any wires related to the turn signal switch with the wire colors you mentioned. Not even a yellow/brown wire in the whole manual. There was a brown wire related to the starter solenoid and speed control system, but again, not to the turn signal switch. Hope this helps.
 

·
Registered
Joined
·
325 Posts
Discussion Starter #6
Hmm... thanks for the help everyone!
When I turn on the 4 ways they make the blinking noise, and everything seems fine is there a seperate flasher for the 4 ways and the turnsignals?

Thanks again
 

·
Registered
Joined
·
804 Posts
Yes, there are seperate flashers for turn signals and the 4-ways (emergency lights). The reason I say check fuses is because the 4-ways still worked on my car even though the turn signals wouldn't (turned out to be a bad fuse).
 

·
Registered
Joined
·
325 Posts
Discussion Starter #8
Thanks everyone I will be checking all that today.

Jason
 
1 - 8 of 8 Posts
Top