Vintage Mustang Forums banner
  • Hey everyone! Enter your ride HERE to be a part August's Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
356 Posts
Discussion Starter · #1 ·
Thank you all in advance.
I was driving the car on the freeway yesterday and the turn signals were fine, once I got onto the street, they were just dead. Hazard lights work as does everything else. I've never had this happen so I'm wondering if there's a specific fuse for the turn signals or if the fturn signal flasher failing would just kill the turn signals.
Any one had this happen to them?
 

·
Registered
Joined
·
1,853 Posts
Not my Mustang, but this happened recently to my '72 Ford Ranger--signals quit but the emergency flashers, etc. were all fine. It was the flasher unit itself--there are two separate flashers for the hazard lights and the turn signals. Piece of cake to fix!
 

·
Registered
Joined
·
1,620 Posts
Do the lights light up but not flash? On my 70 this was the flasher unit under dash right side. There are 2 one for turn signals 1 for flashers. Available at autozone etc.
If they dont do anything and are dead it was the fuse on mine.
On my 70 the turn signals were on 1 fuse flashers on another.
Just look for a blown fuse
Jan Bauer
70 Mach 1
 

·
Registered
Joined
·
916 Posts
I had a similar problem and after inspection of the turn signal cam found that a couple of the copper contacts seated in the plastic somehow heated up and pushed themselves out. If this is the problem, just heat those up a little and push them back in.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top